Guia Epsilon Linux/actualització del sistema

Salta a la navegació Salta a la cerca

Actualitzar el sistema i les aplicacions

Si una nova versió d'algun paquet instal·lat al teu sistema està disponible, podreu actualitzar-lo. Pot ser una actualització de seguretat d'algun component del sistema operatiu, pot ser una optimització a una llibreria especifica o pot ser una nova versió de Firefox. Bàsicament, el vostre sistema està fet de paquets i qualsevol part d'ell pot ser actualitzada obtenint una actualització de paquets. Això vol dir reemplaçar el paquet actual amb una nova versió.

Hi han moltes maneres d'actualitzar però nomes una d'elles es la recomanada. Podeu utilitzar APT per actualitzar tots els paquets amb una simple instrucció ("apt upgrade"), o podeu utilitzar Synaptic i clicar al botó "Marca totes les Actualitzacions", els creadors de Linux Mint, que és d'on neix Epsilon Linux no ho recomanen. Així doncs, to i que el que escriu aquest article no hi està del tot d'acord, pot ser millor fer-los cas i utilitzeu el gestor d'actualitzacions mintUpdate que bé inclòs a Epsilon Linux.

Algunes parts del sistema són segures d'actualitzar i altres no ho són. Per exemple, actualitzar el vostre nucli o "kernel" (la part encarregada entre altres coses de reconèixer el hardware) podria trencar el vostre suport de so, el vostre suport de la targeta wireless o altres aplicacions com VMWare o Virtualbox, que estan estretament relacionades amb el kernel.

Fent servir el Gestor d'actualitzacions mintUpdate

Epsilon Linux inclou un gestor d'actualitzacions anomenat MintUpdate. Et dóna més informació sobre les actualitzacions i permet escollir quines voleu aplicar. Sembla un escut i es troba situada al botó del cantó dret de la pantalla. En el cas que tingueu actualitzacions disponibles l'escut tindrà una lletra “i” dins un cercle blau.

Update info.png

Si poseu el punter del ratolí sobre ell, us dirà la quantitat d'actualitzacions disponibles. En el cas de tindre el sistema actualitzat, dins de l'escut hi veureu un símbol de color verd.

Update ok.png

Fixeu-vos que, en les captures anteriors, l'escut d'actualitzacions és ubicat a llocs diferents. Això es deu al fet que el quadre de notificacions es pot personalitzar segons a un li agradi.

Si feu clic a l'ecut s'obrirà MintUpdate i mostrarà les actualitzacions disponibles. La interfície és molt senzilla d'utilitzar. Per a qualsevol paquet d'actualització podeu llegir la descripció, el registre de canvis (aquí es on els desenvolupadors escriuen els canvis quan modifiquen el paquet), i ocasionalment si Linux Mint afegeix avisos assignats o informació extra sobre les actualitzacions. També podeu veure la versió que teniu instal·lada actualment al sistema i quina versió esta disponible per a actualitzar. Finalment, podeu veure el nivell d'estabilitat assignat a aquest paquet. Cada paquet d'actualització aporta millores o correccions de seguretat però no vol dir que estiguin exemptes de risc, i poden introduir nous errors. El nivell d'estabilitat es assignat a cada paquet per Linux Mint i us dóna una indicació de com de segur es aplicar aquesta actualització.

Evidentment, podeu clicar sobre les columnes per ordenar-les segons el nivell d'estabilitat, estat, nom de paquet o per versió. Podeu seleccionar totes les actualitzacions o deseleccionar-les totes utilitzant els botons "Selecciona tot" i "Neteja".

Les actualitzacions de Nivell 1 i Nivell 2 no comporten cap risc i les hauríeu d'aplicar sempre. Les actualitzacions de Nivell 3 "haurien de ser segures" i encara que us recomanem aplicar-les, assegureu-vos de mirar la llista d'actualitzacions sencera abans d'aplicar-les. Si teniu algun problema amb alguna actualització de Nivell 3 en particular, l'equip de desenvolupament de Linux Mint pot prendre mesures per passar aquesta actualització a Nivell 4 o Nivell 5, per tal d'alertar o desanimar a altres persones d'aplicar- la.

Mint update.png

Si cliqueu al botó "Preferències" hauríeu de poder veure la pantalla superior. Per defecte, MintUpdate us mostra les actualitzacions de Nivell 1, 2, i 3. Podeu decidir si fer "visibles" les de Nivell 4 i 5. En conseqüència, apareixeran més actualitzacions a la llista.

Si voleu (no es recomanable en cap cas) podeu fer segures les actualitzacions de Nivell 4 i 5. En conseqüència seran seleccionades per defecte amb MintUpdate.

MintUpdate només té en compte les actualitzacions "segures". Així, quan us diu si el vostre sistema està actualitzat, significa que no existeixen actualitzacions disponibles amb els nivells que heu definit com a "segurs".

MintUpdate nomes mostra les actualitzacions "visibles" a la llista.

Per exemple, si classifiqueu tots els nivells com a "visibles" i només els Nivell 1 i 2 com a "segurs", podreu veure moltes actualitzacions a la llista. Però MintUpdate probablement us dirà que el vostre sistema està actualitzat.

La pestanya “Comprovació automàtica" us permet definir la freqüència amb què MintUpdate comprova si hi ha actualitzacions.

La pestanya "Mètode d'actualització" us permet definir si MintUpdate ha d'instal·lar noves dependències o no. Per exemple, si paquetA versió 1 es va instal·lar al vostre sistema i paquetA versió 2 esdevé disponible, però la versió 2 té una nova dependència a paquetB que no es troba instal·lat al sistema... què podria passar?

Si deixeu aquesta casella sense marcar, la versió 2 no apareixerà com una actualització a la llista d'actualitzacions.

Si marqueu aquesta casella, la versió 2 sí que apareixerà i el paquetB s'instal·larà com a dependència.

Aneu amb compte amb aquesta opció, ja que les dependències poden instal·lar nous paquets per vosaltres, però també poden esborrar paquets que teniu instal·lats.

La darrera pestanya us permet canviar les icones utilitzades per MintUpdate a la safata de sistema.

Nota: Si apareixen errors amb MintUpdate ("No podeu refrescar la llista de paquets" per exemple) podeu comprovar els logs de MintUpdate. Feu clic dret a la icona del cadenat de la safata del sistema i seleccioneu "Informació". En aquesta pantalla podeu veure l'ID del procés de mintUpdate, si està funcionant amb permisos d'usuari o de root, i el contingut del fitxer de log.